Computer Requirements for Using Moodle

To access your Moodle course(s), you will need to have:

  • A reliable connection to the Internet.
  • A recommended web browser with javascript and cookies enabled
  • Pop-up blockers disabled.

Recommended Web Browsers

Not all browsers fully support Moodle functions. The following are the browsers the Onlinehelp Desk supports for Moodle use:

For PCs

  • Internet Explorer: versions 9.0 or later
  • Mozilla Firefox: latest version

For Macs

  • Mozilla Firefox: latest version

Browsers not listed above may lack some Moodle functionality and are NOT supported by the Onlinehelp Desk.

If you are not certain what version of web browser you are using, open your browser and:

  • Click on the HELP function in your browser.
  • Find and select the text that says (for example) “About Internet Explorer”. You will then see a page describing what version you are using.

 

Onlinehelp

  • Contact
    Phone (North America)
    » 250.721.8476
    » 1.888.721.8476 (toll-free)
    Phone (International)
    » 00.1.250.721.8476
    E-mail TILhelp@uvic.ca
  • Hours (Pacific Time)
    Monday to Thursday
    » 8:30 am to 7:00 pm
    Friday
    » 8:30 am to 6:00 pm
    Saturday & Sunday
    » 10:00 am to 4:00 pm

Calendars

Feedback

Related links