Computer requirements for using Blackboard Collaborate

To use Blackboard Collaborate, you will need to have:

  • A reliable, 28.8 Kbps (minimum) Internet connection.
  • 20 MB free disk space.
  • A soundcard with speakers and microphone or a headset (with a microphone).
  • Windows XP, Vista (32 or 64-bit) or 7 (32 or 64-bit).
    OR
    Mac OS X 10.6 or above.
  • Java, which will allow you to launch a Blackboard Collaborate session (go to the Browser Test page in this Startup Kit for further information.)
  • A recommended web browser with cookies enabled (for confirmation that you have cookies enabled, or for help with this, go to the Browser Testpage in this Startup Kit.)

Recommended web browsers

Not all browsers fully support Blackboard Collaborate functions. The following web browsers are recommended for use with Blackboard Collaborate (and are supported by the Onlinehelp Desk):

For Windows:

  • Internet Explorer: versions 7.0 or higher
  • Mozilla Firefox: version 3.6 or higher

For Mac OS:

  • Mozilla Firefox: version 3.6 or higher
  • Safari: version 4.x

If you are not certain what version of web browser you are using, open your browser and:

  • Click on the HELP function in your browser.
  • Find and select the text that says (for example) “About Internet Explorer”. Your browser will show you a page describing what version you are using.

Blackboard Collaborate browser test

To see if your computer and web browser are configured to use Blackboard Collaborate, go to the Browser Test page in this Startup Kit.

 

Onlinehelp

  • Contact
    Phone (North America)
    » 250.721.8476
    » 1.888.721.8476 (toll-free)
    Phone (International)
    » 00.1.250.721.8476
    E-mail TILhelp@uvic.ca
  • Hours (Pacific Time)
    Monday to Thursday
    » 8:30 am to 7:00 pm
    Friday
    » 8:30 am to 6:00 pm
    Saturday & Sunday
    » 10:00 am to 4:00 pm

Calendars

Feedback

Related links